Fehler: "Radio spinnt, geht an/aus, Menüeinträge im Kombiinstrument verschwinden"

Plötzlich geht das Radio unvermittelt aus und sämtliche Menüeinträge für die Radio/Navigation verschwinden aus der Anzeige im Kombiinstrument:

Kurz darauf kommt alles wie von Geisterhand zurück. Die Intervalle zwischen Wegfall und Wiederkehr können unterschiedlich lang sein, zwischen wenigen Sekunden bis zu Stunden.

Auch am Radio können Effekte wie die fehlende Datum/Uhrzeitanzeige, oder die Meldung „Ohne laufenden Motor schaltet sich das Gerät nach 1 Stunde ab“ auf ein Problem im CAN-Bus hindeuten.

:i: Dieses Problem kann auch durch defekte RAM-Chips im Radio verursacht werden. Bitte also auch diese Fehlerprüfung in Betracht ziehen. Die Symptome sind exakt dieselben.

Das Problem entsteht im Kombiinstrument selbst. Dieses steuert nämlich den sog. „Multi-Media CAN-Bus“ (kurz „MM-CAN“) welcher die Audiosysteme im Mondeo miteinander verbindet. Defekte Lötstellen im Kombiinstrument lassen diesen Bus ausfallen und somit fällt die Kommunikation zu den Geräten weg, was für das Kombiinstrument aussieht als wären diese Komponenten ausgefallen oder nicht vorhanden. Daher passt es die Menüeinträge entsprechend an.

Mit ein paar einfachen Handgriffen kann man selbst schnell herausfinden ob dieser Fehler vorliegt. Hierzu Zündung und Radio einschalten und mit dem Daumen am Rand des Kombiinstrumentes entlang drücken:

Ändert sich das Verhalten, sprich fallen plötzlich die Menüeinträge weg oder erscheinen wieder, liegt sehr sicher dieses Problem vor. Sollte dieser Test kein Ergebnis bringen empfehle ich das Kombiinstrument auszubauen, aber angesteckt zu lassen. Dann wieder die Zündung und Radio einschalten und das Kombiinstrument links und rechts mit den Händen greifen und eine verwindende, gegenläufige Drehbewegung durchführen, so als wolle man es „auswringen“:

Das ganze zwar schon beherzt, aber natürlich mit Gefühl. Spätestens jetzt sollte sich der Effekt einstellen. Wenn auch das kein Ergebnis bringt bleibt noch ein allerletzter Test um völlige Gewissheit zu haben. Dazu entfernt man die rückseitige Schutzkappe vom KI im ausgebauten Zustand:

<FOTO>

lokalisiert den Zentralprozessor und drückt leicht mit einem Finger auf äußeren Pins (markiert als „Bad pins“ im Bild):

Keine Angst, das Gerät arbeitet mit Spannungen die für Menschen völlig ungefährlich sind. Und man kann durch leichtes drücken auch nichts beschädigen.

Waren alle diese Tests ohne Ergebnis ist es eher unwahrscheinlich das es sich um das genannte Problem mit den fehlerhaften Lötstellen handelt. In diesem Fall empfehle ich das Radio selbst zu untersuchen.

Das Problem entsteht aufgrund der Tatsache das in der Industrie seit vielen Jahren ausschließlich bleifreie Lote verwendet werden dürfen. Dies führte zwar zu einer besseren Umwelt- und Gesundheitswirkung, jedoch fehlten damit auch wichtige Eigenschaften des Lotes. Eine war, das es im laufe der Jahre dazu neigt zu „brechen“ und sich dadurch sog. „kalte Lötstellen“ ergeben. Dabei geht der eigentlich durch das Lot herzustellende Kontakt zwischen Platine und Bauteil (Beinchen) nach und nach verloren.

Einer dieser Problemstellen im Typ 3 Kombiinstrument befindet sich um den Zentralprozessor (MAC7116), hier im Bild mit (1) markiert:

Die Reparatur dieses Problems klingt trivial: Das schadhafte Lot ersetzen.

Die Umsetzung gelingt jedoch nur mit entsprechender Sachkenntnis und geeigneter Werkstattausrüstung eines Elektronikers. Das vorhandene Lot einfach zu erwärmen kann das Problem kurzfristig beheben, jedoch nicht dauerhaft, da dem Lot einfach gewisse Fließeigenschaften fehlen. Den besten Effekt erziehlt man indem man den Prozessor vollständig auslötet, das Zinn von der Platinenoberfläche entfernt und wieder mit neuem Lot einlötet.

Besonders häufig ist dieser Bereich betroffen, welcher auch direkt die Signale des MM-CAN Bus enthält:

  • artikel/ipc/ipc_typ3_mmcan_fehler_reparieren.txt
  • von wikiadmin